...
 
Commits (2)
......@@ -8,6 +8,7 @@
# dependencies
/bower_components/
/node_modules/
# misc
/coverage/
......
module.exports = {
root: true,
parserOptions: {
ecmaVersion: 2017,
ecmaVersion: 2018,
sourceType: 'module'
},
plugins: [
......@@ -20,20 +20,30 @@ module.exports = {
// node files
{
files: [
'.eslintrc.js',
'.template-lintrc.js',
'ember-cli-build.js',
'testem.js',
'blueprints/*/index.js',
'config/**/*.js',
'lib/*/index.js'
'lib/*/index.js',
'server/**/*.js'
],
parserOptions: {
sourceType: 'script',
ecmaVersion: 2015
sourceType: 'script'
},
env: {
browser: false,
node: true
}
},
plugins: ['node'],
rules: Object.assign({}, require('eslint-plugin-node').configs.recommended.rules, {
// add your custom rules and overrides for node files here
// this can be removed once the following is fixed
// https://github.com/mysticatea/eslint-plugin-node/issues/77
'node/no-unpublished-require': 'off'
})
}
]
};
......@@ -9,6 +9,8 @@
/node_modules/
# misc
/.env*
/.pnp*
/.sass-cache
/connect.lock
/coverage/
......
---
language: node_js
node_js:
- "6"
- "8"
sudo: false
dist: trusty
......
......@@ -9,7 +9,7 @@ module.exports = function(environment) {
EmberENV: {
FEATURES: {
// Here you can enable experimental features on an ember canary build
// e.g. 'with-controller': true
// e.g. EMBER_NATIVE_DECORATOR_SUPPORT: true
},
EXTEND_PROTOTYPES: {
// Prevent Ember Data from overriding Date.parse.
......
This diff is collapsed.
......@@ -18,19 +18,19 @@
"test": "ember test"
},
"devDependencies": {
"@ember/jquery": "^0.5.2",
"@ember/optional-features": "^0.6.3",
"broccoli-asset-rev": "^2.7.0",
"ember-ajax": "^3.1.0",
"@ember/jquery": "^0.6.0",
"@ember/optional-features": "^0.7.0",
"broccoli-asset-rev": "^3.0.0",
"ember-ajax": "^5.0.0",
"ember-charts": "^1.2.2",
"ember-cli": "~3.5.0",
"ember-cli": "~3.11.0",
"ember-cli-accounting": "^2.0.2",
"ember-cli-app-version": "^3.2.0",
"ember-cli-babel": "^6.17.2",
"ember-cli-dependency-checker": "^3.0.0",
"ember-cli-eslint": "^4.2.3",
"ember-cli-htmlbars": "^3.0.0",
"ember-cli-htmlbars-inline-precompile": "^1.0.3",
"ember-cli-babel": "^7.7.3",
"ember-cli-dependency-checker": "^3.2.0",
"ember-cli-eslint": "^5.1.0",
"ember-cli-htmlbars": "^3.0.1",
"ember-cli-htmlbars-inline-precompile": "^2.1.0",
"ember-cli-inject-live-reload": "^1.10.2",
"ember-cli-moment-shim": "^3.7.1",
"ember-cli-sass": "^7.2.0",
......@@ -39,30 +39,31 @@
"ember-cli-template-lint": "^1.0.0-beta.1",
"ember-cli-uglify": "^2.1.0",
"ember-cli-update": "^0.27.3",
"ember-data": "~3.5.0",
"ember-data": "~3.11.0",
"ember-export-application-global": "^2.0.0",
"ember-href-to": "^1.15.1",
"ember-link-action": "^0.1.2",
"ember-load-initializers": "^1.1.0",
"ember-load-initializers": "^2.0.0",
"ember-math-helpers": "^2.7.1",
"ember-maybe-import-regenerator": "^0.1.6",
"ember-moment": "^7.8.0",
"ember-paper-link": "0.0.2",
"ember-paper-pikaday": "^2.0.3",
"ember-percy": "^1.5.0",
"ember-qunit": "^3.4.1",
"ember-qunit": "^4.4.1",
"ember-resolver": "^5.0.1",
"ember-simple-auth": "^1.7.0",
"ember-source": "~3.5.0",
"ember-source": "~3.11.1",
"ember-transition-helper": "0.0.6",
"ember-welcome-page": "^3.2.0",
"eslint-plugin-ember": "^5.2.0",
"ember-welcome-page": "^4.0.0",
"eslint-plugin-ember": "^6.2.0",
"eslint-plugin-node": "^9.0.1",
"liquid-fire": "^0.29.5",
"loader.js": "^4.7.0",
"qunit-dom": "^0.8.0"
"qunit-dom": "^0.8.4"
},
"engines": {
"node": "6.* || 8.* || >= 10.*"
"node": "8.* || >= 10.*"
},
"dependencies": {
"ember-paper": "^1.0.0-beta.18"
......